$re = '~->(\d+)~m';
$str = 'channel->0->item->0->guid->0';
$subst = "[\1]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;