use strict;
my $str = 'channel->0->item->0->guid->0';
my $regex = qr~->(\d+)~mp;
my $subst = '[\\1]';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";