const regex = new RegExp('->(\\d+)', 'gm')
const str = `channel->0->item->0->guid->0`;
const subst = `[\1]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);