#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\^(\d+)"
Local $sString = "10x^2-8y^2-7k^4=0"
Local $sSubst = "<sup>\1</sup>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)