package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\^(\d+)`)
var str = `10x^2-8y^2-7k^4=0`
var substitution = "<sup>\1</sup>"
fmt.Println(re.ReplaceAllString(str, substitution))
}