use strict;
my $str = '10x^2-8y^2-7k^4=0';
my $regex = qr/\^(\d+)/p;
my $subst = '<sup>\\1</sup>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";