$re = '/\^(\d+)/';
$str = '10x^2-8y^2-7k^4=0';
$subst = "<sup>\1</sup>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;