using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\^(\d+)";
string substitution = @"<sup>\1</sup>";
string input = @"10x^2-8y^2-7k^4=0";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}