const regex = new RegExp('\\^(\\d+)', 'g')
const str = `10x^2-8y^2-7k^4=0`;
const subst = `<sup>\1</sup>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);