using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"__\(\s?((['""])(((?!(?<!\\)\2).)*)\2), 'wprss'\s?\)";
string substitution = @"__( $1, MY_TEXT_DOMAIN )";
string input = @"__( 'Export & Import S\'ettings', 'wprss' ), __( 'Import & Export', 'wprss' ), apply_filters( ' $";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}