$re = '/__\(\s?(([\'"])(((?!(?<!\\\\)\2).)*)\2), \'wprss\'\s?\)/';
$str = '__( \'Export & Import S\\\'ettings\', \'wprss\' ), __( \'Import & Export\', \'wprss\' ), apply_filters( \' $';
$subst = "__( $1, MY_TEXT_DOMAIN )";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;