use strict;
my $str = '__( \'Export & Import S\\\'ettings\', \'wprss\' ), __( \'Import & Export\', \'wprss\' ), apply_filters( \' $';
my $regex = qr/__\(\s?((['"])(((?!(?<!\\)\2).)*)\2), 'wprss'\s?\)/p;
my $subst = '__( $1, MY_TEXT_DOMAIN )';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";