import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "__\\(\\s?((['\"])(((?!(?<!\\\\)\\2).)*)\\2), 'wprss'\\s?\\)";
final String string = "__( 'Export & Import S\\'ettings', 'wprss' ), __( 'Import & Export', 'wprss' ), apply_filters( ' $";
final String subst = "__( $1, MY_TEXT_DOMAIN )";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}