const regex = /__\(\s?((['"])(((?!(?<!\\)\2).)*)\2), 'wprss'\s?\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('__\\(\\s?(([\'"])(((?!(?<!\\\\)\\2).)*)\\2), \'wprss\'\\s?\\)', 'g')
const str = `__( 'Export & Import S\\'ettings', 'wprss' ), __( 'Import & Export', 'wprss' ), apply_filters( ' \$`;
const subst = `__( $1, MY_TEXT_DOMAIN )`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);