#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\n|^|\.|\/)[\w\-]+\.[\w\-]+(?=\n|\/|$)"
Local $sString = "*.facebook.com" & @CRLF & _
"facebook.com" & @CRLF & _
"*.xz.fbcdn.net" & @CRLF & _
"messenger.com" & @CRLF & _
"fb.com" & @CRLF & _
"*.m.facebook.com" & @CRLF & _
"*.fbsbx.com" & @CRLF & _
"*.xy.fbcdn.net" & @CRLF & _
"*.messenger.com" & @CRLF & _
"*.fb.com" & @CRLF & _
"*.fbcdn.net" & @CRLF & _
"*.xx.fbcdn.net" & @CRLF & _
"*.facebook.net" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")