using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\n|^|\.|\/)[\w\-]+\.[\w\-]+(?=\n|\/|$)";
string input = @"*.facebook.com
facebook.com
*.xz.fbcdn.net
messenger.com
fb.com
*.m.facebook.com
*.fbsbx.com
*.xy.fbcdn.net
*.messenger.com
*.fb.com
*.fbcdn.net
*.xx.fbcdn.net
*.facebook.net
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}