re = /(?<=\n|^|\.|\/)[\w\-]+\.[\w\-]+(?=\n|\/|$)/
str = '*.facebook.com
facebook.com
*.xz.fbcdn.net
messenger.com
fb.com
*.m.facebook.com
*.fbsbx.com
*.xy.fbcdn.net
*.messenger.com
*.fb.com
*.fbcdn.net
*.xx.fbcdn.net
*.facebook.net
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end