import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\n|^|\\.|\\/)[\\w\\-]+\\.[\\w\\-]+(?=\\n|\\/|$)";
final String string = "*.facebook.com\n"
+ "facebook.com\n"
+ "*.xz.fbcdn.net\n"
+ "messenger.com\n"
+ "fb.com\n"
+ "*.m.facebook.com\n"
+ "*.fbsbx.com\n"
+ "*.xy.fbcdn.net\n"
+ "*.messenger.com\n"
+ "*.fb.com\n"
+ "*.fbcdn.net\n"
+ "*.xx.fbcdn.net\n"
+ "*.facebook.net\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}