$re = '/(?<=\n|^|\.|\/)[\w\-]+\.[\w\-]+(?=\n|\/|$)/';
$str = '*.facebook.com
facebook.com
*.xz.fbcdn.net
messenger.com
fb.com
*.m.facebook.com
*.fbsbx.com
*.xy.fbcdn.net
*.messenger.com
*.fb.com
*.fbcdn.net
*.xx.fbcdn.net
*.facebook.net
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);