import Foundation
let pattern = #"(?<=\n|^|\.|\/)[\w\-]+\.[\w\-]+(?=\n|\/|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
*.facebook.com
facebook.com
*.xz.fbcdn.net
messenger.com
fb.com
*.m.facebook.com
*.fbsbx.com
*.xy.fbcdn.net
*.messenger.com
*.fb.com
*.fbcdn.net
*.xx.fbcdn.net
*.facebook.net
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)