# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a.*?(<img.*?>)<\\/a>/$1/;t' <<< "<a href=\"something.html\" alt=\"blah\"><img src=\"image1.jpg\" alt=\"image 1\"></a>"