use strict;
my $str = '<a href="something.html" alt="blah"><img src="image1.jpg" alt="image 1"></a>';
my $regex = qr/<a.*?(<img.*?>)<\/a>/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";