#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<a.*?(<img.*?>)<\/a>"
Local $sString = "<a href="something.html" alt="blah"><img src="image1.jpg" alt="image 1"></a>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)