using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?(<img.*?>)<\/a>";
string substitution = @"$1";
string input = @"<a href=""something.html"" alt=""blah""><img src=""image1.jpg"" alt=""image 1""></a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}