re = /<a.*?(<img.*?>)<\/a>/
str = '<a href="something.html" alt="blah"><img src="image1.jpg" alt="image 1"></a>'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result