$re = '/<a.*?(<img.*?>)<\/a>/';
$str = '<a href="something.html" alt="blah"><img src="image1.jpg" alt="image 1"></a>';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;