#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:2018|201[0-7]|200[0-9]|1[0-9]{1,3}|[0-9]{1,3})$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"9" & @CRLF & _
"10" & @CRLF & _
"40" & @CRLF & _
"100" & @CRLF & _
"101" & @CRLF & _
"229" & @CRLF & _
"400" & @CRLF & _
"777" & @CRLF & _
"888" & @CRLF & _
"999" & @CRLF & _
"1000" & @CRLF & _
"1001" & @CRLF & _
"1799" & @CRLF & _
"1800" & @CRLF & _
"1900" & @CRLF & _
"2001" & @CRLF & _
"2016" & @CRLF & _
"2018" & @CRLF & _
"2019" & @CRLF & _
"2020" & @CRLF & _
"3000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")