import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:2018|201[0-7]|200[0-9]|1[0-9]{1,3}|[0-9]{1,3})$";
final String string = "0\n"
+ "1\n"
+ "2\n"
+ "9\n"
+ "10\n"
+ "40\n"
+ "100\n"
+ "101\n"
+ "229\n"
+ "400\n"
+ "777\n"
+ "888\n"
+ "999\n"
+ "1000\n"
+ "1001\n"
+ "1799\n"
+ "1800\n"
+ "1900\n"
+ "2001\n"
+ "2016\n"
+ "2018\n"
+ "2019\n"
+ "2020\n"
+ "3000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}