import re
regex = re.compile(r"^(?:2018|201[0-7]|200[0-9]|1[0-9]{1,3}|[0-9]{1,3})$", flags=re.MULTILINE)
test_str = ("0\n"
"1\n"
"2\n"
"9\n"
"10\n"
"40\n"
"100\n"
"101\n"
"229\n"
"400\n"
"777\n"
"888\n"
"999\n"
"1000\n"
"1001\n"
"1799\n"
"1800\n"
"1900\n"
"2001\n"
"2016\n"
"2018\n"
"2019\n"
"2020\n"
"3000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")