re = /^(?:2018|201[0-7]|200[0-9]|1[0-9]{1,3}|[0-9]{1,3})$/m
str = '0
1
2
9
10
40
100
101
229
400
777
888
999
1000
1001
1799
1800
1900
2001
2016
2018
2019
2020
3000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end