use strict;
my $str = '0
1
2
9
10
40
100
101
229
400
777
888
999
1000
1001
1799
1800
1900
2001
2016
2018
2019
2020
3000';
my $regex = qr/^(?:2018|201[0-7]|200[0-9]|1[0-9]{1,3}|[0-9]{1,3})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}