#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\b[a-z0-9]+=[a-z0-9]+\b;\s*)*$"
Local $sString = "key=value;" & @CRLF & _
"key1=value1; key2=value2;" & @CRLF & _
"key=value1;key=value2;;" & @CRLF & _
"key==valu1;;, =value;, key=;, " & @CRLF & _
"key=value" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")