using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\b[a-z0-9]+=[a-z0-9]+\b;\s*)*$";
string input = @"key=value;
key1=value1; key2=value2;
key=value1;key=value2;;
key==valu1;;, =value;, key=;,
key=value
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}