package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\b[a-z0-9]+=[a-z0-9]+\b;\s*)*$`)
var str = `key=value;
key1=value1; key2=value2;
key=value1;key=value2;;
key==valu1;;, =value;, key=;,
key=value
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}