re = /^(?:\b[a-z0-9]+=[a-z0-9]+\b;\s*)*$/m
str = 'key=value;
key1=value1; key2=value2;
key=value1;key=value2;;
key==valu1;;, =value;, key=;,
key=value
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end