// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\b[a-z0-9]+=[a-z0-9]+\b;\s*)*$").unwrap();
let string = "key=value;
key1=value1; key2=value2;
key=value1;key=value2;;
key==valu1;;, =value;, key=;,
key=value
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}