use strict;
my $str = 'key=value;
key1=value1; key2=value2;
key=value1;key=value2;;
key==valu1;;, =value;, key=;,
key=value
';
my $regex = qr/^(?:\b[a-z0-9]+=[a-z0-9]+\b;\s*)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}