using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(^|/)thumbs\.db$";
string input = @"thumbs.db
a/thumbs.db
a/b/thumbs.db
a/b/thumbs.dblala
a/b/thumbs.db.lala";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}