re = /(?i)(^|\/)thumbs\.db$/m
str = 'thumbs.db
a/thumbs.db
a/b/thumbs.db
a/b/thumbs.dblala
a/b/thumbs.db.lala'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end