$re = '`(?i)(^|/)thumbs\.db$`m';
$str = 'thumbs.db
a/thumbs.db
a/b/thumbs.db
a/b/thumbs.dblala
a/b/thumbs.db.lala';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);