package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(^|/)thumbs\.db$`)
var str = `thumbs.db
a/thumbs.db
a/b/thumbs.db
a/b/thumbs.dblala
a/b/thumbs.db.lala`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}