import re
regex = re.compile(r"(?i)(^|/)thumbs\.db$", flags=re.MULTILINE)
test_str = ("thumbs.db\n\n"
"a/thumbs.db\n\n"
"a/b/thumbs.db\n\n"
"a/b/thumbs.dblala\n\n"
"a/b/thumbs.db.lala")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")