#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(2[0-9]+)"
Local $sString = "2019 RTM-CU8" & @CRLF & _
"2017 RTM-CU10" & @CRLF & _
"2016 SP2-CU14" & @CRLF & _
"2017 RTM-CU31" & @CRLF & _
"2019 RTM-CU14" & @CRLF & _
"2016 SP2-CU7" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")