use strict;
my $str = '2019 RTM-CU8
2017 RTM-CU10
2016 SP2-CU14
2017 RTM-CU31
2019 RTM-CU14
2016 SP2-CU7
';
my $regex = qr/(2[0-9]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}