re = /(2[0-9]+)/m
str = '2019 RTM-CU8
2017 RTM-CU10
2016 SP2-CU14
2017 RTM-CU31
2019 RTM-CU14
2016 SP2-CU7
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end