// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(2[0-9]+)").unwrap();
let string = "2019 RTM-CU8
2017 RTM-CU10
2016 SP2-CU14
2017 RTM-CU31
2019 RTM-CU14
2016 SP2-CU7
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}