const regex = /(2[0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(2[0-9]+)', 'gm')
const str = `2019 RTM-CU8
2017 RTM-CU10
2016 SP2-CU14
2017 RTM-CU31
2019 RTM-CU14
2016 SP2-CU7
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}