using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(2[0-9]+)";
string input = @"2019 RTM-CU8
2017 RTM-CU10
2016 SP2-CU14
2017 RTM-CU31
2019 RTM-CU14
2016 SP2-CU7
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}