using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{3}\.\d{3}\.\d{3}\s{3}(?:.*\/ )?(.+)$";
string input = @"030.000.208 OUTRA COISA
001.005.001 ALGUMA / COISA AQUI COM - TAMBÉM / GERAL.ASSINADA-COISA
040.001.218 OUTRA COISA / AQUI OUTRA/COISA GERAL
000.000.003 ALGUMA / COISA AQUI COM - TAMBÉM";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}