$re = '/^\d{3}\.\d{3}\.\d{3}\s{3}(?:.*\/ )?(.+)$/m';
$str = '030.000.208 OUTRA COISA
001.005.001 ALGUMA / COISA AQUI COM - TAMBÉM / GERAL.ASSINADA-COISA
040.001.218 OUTRA COISA / AQUI OUTRA/COISA GERAL
000.000.003 ALGUMA / COISA AQUI COM - TAMBÉM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);